• don
    0
    Hey guys,

    Picked up a Waxxy a while back and decided I'd try the Galaxy for the purer taste what with getting rid of the silica wicks and whatnot.

    I am using Michigan MMJ certified concentrates from a place that does lab testing.

    I used the awesome coupon from Bud and got an extra atomizer, but it seems the first one that it came with is getting shorted somehow? One coil is turning red (and is the one that turned black) and the other coil doesn't turn red at all until the other one heats it up to a faint glow. Is there anything I can do to try and salvage it without having to buy another one? Going to try washing this one out but I feel like the mechanical short might circumvent any benefit of washing it in ISO

    Thanks for your time guys,
    Don
  • Flipz
    483
    Your right, both atomizers should heat up to orange and work the same. Check your inbox.
  • Fulkersonic
    0
    hey, I had literally the EXACT same issue, and I was curious what resolution you came to concerning this.

    Thanks in advance for the help,

    Dave
  • don
    0
    I have my order number handy if it can help at all.

    Thanks again guys,
    Don
  • Bud
    17k
    hey can u tell me which color galaxy you have?

    Check out these pics, I just took apart a galaxy atomizer so its easier to visualize whats going on in there

    Im thinking perhaps those two wire leads coming out of the bottom might be uneven or one might be not touching the contact at all?

    5hfa1lw1bhbm17yd.jpeg
    kbsjd7sqrxr7qs4t.jpeg
    vn8ulrw126zzmidn.jpeg
    axlm8hohqre5mxtn.jpeg
    ie923pr3k32tb5op.jpeg
    g6ytbaisv9co7i2k.jpeg
    3dqmo7uouhdofbjg.jpeg
    ugr1skq6r5s44weg.jpeg
    ooj0d3gb3wnldm7f.jpeg
    4qbx4aex6nl84wdf.jpeg
  • Bud
    17k
    The attys they send now actually dont have that middle hole anymore:

    mppxblvenabw36dh.jpeg
  • don
    0
    Hey man thanks for the quick reply,
    I have an andromeda colored one, the non matte black.

    After a quick look at the 2 atomizers I have I can't really tell if they're out of place or not, they maybe seem a little recessed compared to yours? Both are seeming to have the same issue where one coil is much redder than the other.

    Here's a shitty pic, let me know if you need a better angle or somethin
    rGxUYk8.jpg

    Edit:

    Ahh I gotcha, now I see the pics with it taken apart.
    Do you need anything special to take it apart safely? Or is the pictured set of pliers enough?


    Thanks again man,
    Don
  • Bud
    17k
    You got it man just the needle nose pliers thats all you need

    Both of those little parts just pull out, just do it slow and gently

    Metal insert comes out first, then the silicone insert
  • don
    0
    I can't really seem to tell, but it almost looks like it's not fully connected to one of the coils. Is there any trick to reassembling the bottom pieces while getting the 2 lead lines through the silicone? Each time it seems the silicone wants to push them away

    Thanks for your time,
    Don
  • Bud
    17k
    Hey so you mean the wires retracted too far inside and don't reach to the end?

    If so you can try very gently pulling them out with the pliers a tiny bit at a time

    Also just keep in mind they're never really 100% perfect in how evenly they heat, usually one gets a little brighter than the other but if you see a very drastic difference it could be something to do with these wire leads

    And you said this only happens with one out of the two atomizers correct?
  • don
    0
    Yeah the wires seemed to get bent inside when I tried to place the silicone insert back in, I was able to fish them out with a toothpick after many tries. I noticed after gently pushing the coils around a bit I was able to get them to fire together, but it was short lived as I imagine I probably hurt something by trying to maneuver the delicate rods around. Now just one of them fires off without the other getting red anymore, but the one I haven't opened up seems to function better, albeit not at 100%.

    It happens with both of them, I was able to replace the silicone and the metal insert on the one but I still can't seem to get them both to fire. My other atomizer heats up one coil, and then if I hit it again after it hits the heat safety off the other coil gets red from either being so hot or just activating somehow after. Since this is what I am using to smoke all of my concentrates as I don't have a rig, I don't want to risk taking this one apart and not threading it through the silicone again. (It took me about an hour of fiddling, my hand dexterity isn't that great after I smashed my hand a few years ago)

    I get pretty decent rips with the one I am using, but I feel like the waxxy almost gave me better hits albeit requiring being packed more and more.

    I am thinking of ordering a new galaxy atomizer from a 3rd party retailer (Thinking of trying vapornation but I haven't used them yet,) to see if I have the same problem.
  • don
    0
    Do you have any tips on replacing the silicone insert while threading the leads properly? Is it even remotely possible that 2 atomizers have the same wiring issue or is it my battery?

    Thanks for your time,
    Don
  • don
    0
    Just got my atomizer from vapornation and it fires both coils unlike the 2 that were shipped with my galaxy. (1 being the free promotional one from the coupon)

    It's a speckled color which is different from my glossy black, but since its black anyway it doesn't really stand out.

    Is there anything I can do to try and fix the originals or am I shit out of luck?


    Thanks a ton,
    Don
  • Bud
    17k
    Hey Don I'm very glad to hear that!! But still bummed and perplexed about the other ones, I'm gonna continue working on what could be wrong with them or how to fix them.

    Please keep us posted on how the new one holds up!

    And please check for a PM in your inbox
  • don
    0
    New one is hitting like a champ! Very clean flavor compared to my last silica wick vape, and it's a dream to pack it up with more than just 1 rip. I really like the hard case it came with too, as it folds up neatly and nicely in just a small pocket.
  • Flipz
    483
    Wow, this post turned into a real nice kandypens galaxy total breakdown guide! I love it!

    (Y) (Y) (Y) for everyone :D
  • don
    0
    Both coils still firing after heavy daily use! Digging this thing
  • don
    0
    Anyone have experience cleaning the atomizers with 92% isopropyl rubbing alcohol?
  • Bud
    17k
    sweet!!

    Yes you can soak it in iso just be gentle and careful not to scratch the finish and do it when the coil is warm
  • XL83
    0
    I had to order a replacement atomizer after only a week, at $40. Now, after 3 weeks, the battery won't connect to either the charger or the atomizer. It's a brick and it's not even a month old. Yeah they will replace it through warranty but in the meantime I'm not hitting any shatter.

    I'm beyond disappointed in this product. I would never buy from them again.
  • Flipz
    483
    Can you be more specific about
    the battery won't connect to either the charger or the atomizer.XL83

    They screw onto each other so not sure how they wouldn't connect. Thanks.
  • XL83
    0
    I mean that no matter how tightly the battery is threaded into the charger or the atomizer, it doesn't actually connect to either. The charger stays on green even though the battery is dead. The coils don't heat up.

    Anyway they are sending a replacement and they were really easy to deal with, so I won't complain too much. I think I may have just got a lemon and that's why I thought my atomizer wasn't working the first time. The battery has never connected properly is my guess. When it did work, it was bliss, which is the main reason I'm so choked about it now.
  • Flipz
    483
    Glad your getting a replacement because I was confused as heck trying to figure it out originally lol. Keep us updated!
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment