• big huggy
    5
    Hey all, new here. Just updated the firmware on my ghost mv1 on an Android phone. Was connecting and working perfectly before the update. Vape is still working but can no longer connect to the app. I tried removing the battery and also deleting and reinstalling the app with no success. Anyone have any suggestions? Or similar experience?

    Thanks!!
  • MothChewMoth
    1.5k
    Try deleting the connection, clearing your Bluetooth cache, then rebooting the phone. The connection could be wonky after the update.
  • Cl4ud3
    2.9k
    Just going to tag @ghost-ops here so they can see the issue even if you clear it.
  • big huggy
    5
    @MothChewMoth Thanks both of you!
    Tried clearing the Bluetooth cache and restarting with no luck. Hopefully @ghost-ops will have something.
  • ghost-ops
    425
    Hi @big huggy

    Sorry to hear about this. My first suggestion would have been as above, clear everything out and start again. If that hasn’t worked as it seems then there is a free app available to check if the Bluetooth has developed a fault - I’m not at my laptop right now but later today I’ll be able to forward these over to you.

    In the meantime however can you let me know what phone you are using the app on? If you have access to another handset you could borrow to install the app on temporarily (ideally an iPhone as iOS is more stable than Android but another Android phone would work as well) then this would also help steer us as to whether there is a fault in the Bluetooth itself or if the problem you’re having might be instead related to the connection between the MV1 and your phone.

    Thanks
    GhostOps
  • ghost-ops
    425
    Hi @big huggy
    Just a follow up to see if you've been able to make any progress. Sorry for the delayed update but here are those instruction I promised you to check the Bluetooth module:

    -Go to the Play Store and look for an app called BLE Scanner (by Bluepixel Technologies)
    -Download the app
    -Open the app and look for 'MV1BOOT'
    -Click the small blue text that says RAW DATA
    -Please provide the number of characters in the string
    -Please provide the last 5 digits of the string

    Let me know what you get from this or if you've fixed yourself up in the meantime.

    Thanks
    GhostOps
  • big huggy
    5
    Hey Ghost. Sorry for the delay. I was on the road. Still having connection issues. Was able to connect with a friend's iPhone, but no luck with my Google pixel.
    So.
    20 characters
    Last 5 = F4F54
  • ghost-ops
    425
    Hi @big huggy
    No problem and likewise sorry it's taken me a couple of days to get back to you. Thanks for the feedback from that app; slightly unusual in fact as those digits would normally suggest the Bluetooth was not working correctly so it's a little surprising that the device did connect to the iPhone you borrowed - copying in @ghostdigitalops for his information so he is aware.

    I think it's quite likely we may need to replace this unit for you, so also copying in one of our CS team @GHOSTTEAM so they're aware. We'll need a couple of additional bits of info from you so if you could send me over your Ghost order number (it'll start 2000...) we can get set a ticket up for you to get the ball rolling on this.

    Thanks
    GhostOps
  • big huggy
    5
    Thanks! I just checked back on this because the issue still hasn't resolved itself. I'm going to forward this thread to support at Ghost.

    Thanks again!
    R
  • ghost-ops
    425
    Thanks @big huggy and sorry you’re still having issues, CS will get this resolved soonest for you.

    Thanks

    Mark
  • big huggy
    5
    All good. Thanks, Mark!
  • h1g3ars
    13
    Hi,

    I have the EXACT issue as described above. My MV1 bluetooth was working just fine and was the means by which I performed the most recent firmware update 1.4(?). So theres no question that bluetooth *was* working prior to the update but then ceased to function properly *after* the update.

    The update has most likely broken my bluetooth functions on my MV-1.

    The MV-1 definitely vapes better on the new firmware. Thanks for that.

    Please help me out.

    -J
  • kebcatmorgan
    376
    I had it as well, what helped was reinstalling the app on my phone.
  • h1g3ars
    13
    Samsung Note8 Android 8.0

    After several phone reboots, I left bluetooth off, then set my MV1 to pairing mode, launched ghost app, tapped reconnect and let it turn on bluetooth and find my MV1.

    For reasons I don'tunderstand, the app informed me the install had not completed and essentially executed a reinstall of firmware 1.4.

    After the firmware reinstall and reset, the app could see my MV1 again.
  • ghost-ops
    425
    @h1g3ars apologies for not getting back to you quicker on this, I have been offline for a few days - glad to see you're all sorted.

    @kebcatmorgan thanks for the useful advice :smile:
  • h1g3ars
    13
    Thanks @kebcatmorgan and @ghost-ops for your timely assistance.

    I'm always happy when a problem like this fixes itself. More typically if something goes wrong w a firmware update (mine displayed "success" upon first completion) the problem is not recoverable unless the system can be coerced to run the update again.

    No question the firmware update has improved battery life, and all around efficiency of the MV1. I love getting a better product through a post purchase firmware update.

    Well done Ghost!

    Mod fixed tags
  • Pat Carter
    19
    Boy I sure wish someone had told me about turning off the bluetooth and letting the app turn the bluetooth back on. I just returned two that would not pair even with 3 Apple care screen sharing tries. Should have stuck with this forum for trouble shooting as ghost was of very little help.
  • ghost-ops
    425
    @Pat Carter
    Hi Pat

    I’m sorry that we seem to have not been able to help you out as we usually manage to. I don’t have sight of all the messages between you and our CS team right now but I can assure you that any oversight has been entirely unintentional - you only have to look through other threads here to see that they are the best around.

    With regards to the messages above in this thread, the MV1 app cannot turn your phone’s Bluetooth on by itself so you’ve not been omitted from some important troubleshooting step. Every problem is different - particularly where apps/phones are concerned - and so we would very much like to continue trying to get you fixed up if you’re still open to the possibility.

    Thanks

    Mark
  • Pat Carter
    19
    Just a refund now is all I'm interested in. I'll never buy a vaporizer with an app again and I already ordered a Hydro Tube starter kit that my BFF donated $100 towards to ease the pain of trying to get your app to work for so long.
  • ColumbusMike
    0
    I'm in the same boat. Recieved my new mv1 stealth trade-in deal Wednesday. Fired it up, paired no problem and then required an update. Update processed 100% without issue but I could not pair it back up after the update. I have tried every combination of Bluetooth, batteey, reboot, reinstall mentioned in the above comments to no avail. I had a friend try to pair with their iPhone "mime was android" with no success. Unfortunately I shipped my trade-in back before I ran into this issue. Submitted a ticket with ghost yesterday
  • Summer
    388
    Fired it up, paired no problem and then required an update.ColumbusMike

    That's odd, cause all the newer units have the latest 1.4 firmware version installed already.
  • ColumbusMike
    0
    That's odd, cause all the newer units have the latest 1.4 firmware version installed already

    That's what I thought too, I just followed the prompts from the app.
  • ghost-ops
    425
    Hi @ColumbusMike
    I tracked down your ticket with CS and noticed you'd included a screenshot of the device info which shows the MV1 on firmware v1.3.4. It's not possible for the device to have shipped with this so the only way I can see this happening is if you didn't have the latest version of the app installed. You've probably deleted and reinstalled at this point in an attempt to get things fixed, but is there a chance that prior to this the app had not been updated for some time?

    Don't worry, there's no right or wrong answer to this and it won't affect how we proceed in the event we can't get your device connected again, but it will help us figure out the root cause of the issue.

    (Tagging @GHOSTTEAM for info)

    Thanks

    Mark
  • ColumbusMike
    0
    @ghost-ops

    My app could have been out of date? I have removed and re-installed it several times over the last couple of days. After successfully pairing last night it still said I needed an update so I'm not sure about all that. Here is a breakdown of what where I was stuck/process

    -----------

    Initial pair

    Update process complete

    App instructs to press both buttons on vape "waiting input"

    When both buttons are pressed as instructed the vape crashes won't re-pair "my original issue"

    Per Ghost instructions I removed the MV1 memory from the android BT setting and could re-pair

    After re-pairing app stated vape was in process of updating.. It would go thru the process of resetting until it gets to the same point of "awaiting input", once both buttons were pressed it would crash and the cycle starts all over again. I went thru this a couple times until I found a spot to break it

    When the app is "awaiting input" remove the battery from the vape, replace and put into pairing mode. App will see it online and connects without issue. The update/reset completed and I all good to go now.

    Something about pressing both buttons at that particular point of the process was an issue, causing a Crash/loop

    (Tagging @GHOSTTEAM for info)
  • ghost-ops
    425
    Thanks @ColumbusMike I've flagged this with our developers to look into - obviously happy you've managed to get this resolved and we'll be investigating further.

    Thanks

    Mark
  • caddyvape69
    0
    Thanks ColumbusMike been banging my head trying to figure this out just got re paired keep fingers crossed see if it last
  • caddyvape69
    0
    To make a long story short> You could clone about every thing Columbus Mike stated any that was my situation received my ghostmv1 start of 2nd week of Jan. 2019 firmware updated to v1.4 threw the app the unit shipped with outdated firmware in my opinion pulling the battery as Columbus Mike said during searching for input worked Once I was connected it reinstalled firmware for the second time..Now for the good part have had issues other than editing temps in low and medium ranges with app the wheel temp. works editing high or 4th preset all that aside its working great
  • SouthboundPachyderm
    2.2k
    I may have misundetstood but level 4 and 5 are the only customizable settings. You wont be able to adjust the other 3.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to Vape Life Forum!

Sign up free for full access to this site.