• Azn2101
    248
    Hey guys,

    For 4/20 I bought myself a Herbalizer from Maz (@herbalizerrepair or Maxsvapeworld, on ebay) and I seem to be getting much different results than the videos posted by other members and the videos posted by Vitolo at 395°F and the other at 445°F (I haven't pushed it this hard yet) and had a few questions regarding it's status as Maz said he made sure to calibrate the device before sending it out and from what I understand the device is pretty much idiot proof.

    Is it normal for there to be a good few seconds of no vapor at 410°F with the Whip and fan assist on with good dry material?

    Is it normal for ABV at those temps to still have tons of flavor when thrown through a Volcano at 400°F. I don't think the vapor production of the ABV means much as Halogen devices seem to just have a lighter ABV in general.

    I seem to be getting the desired results at around 430°F and have emailed Maz 2 times since recieving the unit and have not gotten a response.

    From what I hear he's a really solid guy and hope he's just busy but I've been wanting one of these for years and for it to be running quite differently from the way people describe it's quick medicating abilities is a bit worrying as I'm aware there is no other support for this device.

    While it's heat up time is impeccable it just doesn't seem to be producing the awesome vapor it's known to have. Just wisps and mostly flavor inhales for the first 3 full inhales without fan assist and then as soon as it seems to get going is as soon as it seems to stop producing vapor. I've tried 3 different grinds and a broken-nug pack, both had ample time to dry out and be easily vaporized by the Volcano & ENano.

    Please let me know if I'm doing something wrong so I can unleash the beast that is the Herbalizer.

    Thanks guys
  • Budjamin
    69
    This is what she gets for not working anymore and telling me "service needed" :nerd:

    ebxuni3irwf6fhdl.jpeg
  • Baron23
    12k
    :scream: :scream: :scream:

    :joke: :lol: :joke: :sweat:
  • Budjamin
    69
    Ok just to clarify I didn't smash it open with a hammer :lol: but would have been a lot cooler if i did...

    I actually like this vape a lot and tried using it a month ago and it wouldn't turn on, screen would just display "Service Needed". So I carefully took it apart to get to the halogen bulb inside, I figured maybe it was burned out. Well it turns out you have to completely take apart the entire thing to get to the bulb, as you can see.

    The bulb looked fine, unfortunately, so i think something else is wrong with it but have no way to troubleshoot it. I also spent 30 mins searching online for the bulb and couldn't find it, i'm not sure it's even made anymore or maybe it was custom.

    Someone needs to make a simplified (and cheaper) version of this vape, the halogen bulb is really good for temp control, i miss it :groan:
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment