• ZekeElliott
    0
    Hey guys, hoping someone here may know what's going on with my Gravity pen (by Kandypens.) It was working fine for awhile, but now it doesn't heat up when I press the button. It still lights up normally, it still changes heat settings when I tell it to, and it still LOOKS like it should be working - it just won't heat up. I've tried using the included ceramic atomizer as well as the double coil atomizer, and neither are heating up. I also tried a Galaxy atomizer, and that one didn't heat up either.

    Also, when I plug in the pen to charge it, the light on the charger stays at green, which is weird because before, it would appear red until the pen was fully charged, then it would turn green. Even though I used it and know for a fact it's not fully charged, my charger shows green immediately upon plugging it in. I've already contacted Kandypens and they are sending a replacement battery, however it won't arrive for 3-5 days, and you know how it is.

    Has anyone else encountered this? Could the battery have gotten too low or something? Is there any way to fix it by disassembling and tinkering with the connections? I'd really like to see if I can get this working again temporarily, as I'm not really in a position to go get another means of hitting my wax right now.
  • Flipz
    476
    sorry to hear that. sounds like a bad battery to me but I don't know of any way to open it up to fix it.
  • ZekeElliott
    0
    Yeah, doesn't seem like this battery really lends itself to being tinkered with :/ guess I'll have to suck it up and wait.
  • Beamer
    67
    Lesson learned for this cat....gotta have a back up!
  • iizmk
    1
    Having the same issue today have been trying to get my pen up but it doesn't soon as i plug ti in it goes green

    neither of my atomizers are owrking

    did you call the support team? or email them?

    i think i need to do the same this started happening yesterday now the pen wont even warm up and the temp light changes i can turn it on and off but thats about it.
  • Code Monkey
    23
    I've had this issue a few times with my Gravity and Donuts atomizers. The wax seems to pool underneath the the ceramic element, and somehow lift it up enough to cause a short in the wires or something.

    Thankfully, it's been really easy to fix in my case. I take a toothpick and push down on the ceramic gently a few times. After that, it heats up like normal. The battery drives other atomizers with no issue. Not sure if my case is common, but it's worked out for me so far. X-)
  • chris77fla
    0
    hell ya Code Monkey . i just pushed the coils down and got a monstah hit. i’m on my way to the moon right now ...
  • AVENTUS
    330
    Gravity issues were solved with the ELITE and subsequent kandypens like the PRISM. Haven’t tried the Crystal yet, but am interested in it.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment